Download
(270 Kb)
Download
Updated: 08-15-2012 08:20 AM
Pictures
File Info
Updated:08-15-2012 08:20 AM
Created:07-24-2012 05:42 PM
Downloads:3,544
Favorites:32
MD5:
Custom UI
Version: 2.1
by: Dave [More]
Info at http://uimod.eu/.

Please post suggestions or problems at http://uimod.eu/forums/ or http://forums.thesecretworld.com/showthread.php?t=53205. Comments here are not monitored.
1.2.1:
Updated for TSW 1.1.
1.2:
Added cuiUpdate, put /option cuiUpdate true at the bottom of the script to update the UI.
Added cuiAbilityBar[1-7][XYR] so you can change the position and rotation of each ability. Suggested by Xyleya
Added cuiAbilityBarReflectionA, for those that want to see the reflection. The shadow is still hidden for now. Suggested by Pinstripesc
1.1.1:
Added script and XML templates to make it easier for people to get started.
1.1:
Added scale and alpha. Thanks to Spanka for suggestion.
Optional Files (3)
File Name
Version
Size
Author
Date
Type
0.4
268kB
08-01-2012 07:18 PM
Addon
1.2-2
1kB
07-29-2012 02:08 AM
Patch
004
4kB
07-27-2012 10:49 PM
Patch


Archived Files (4)
File Name
Version
Size
Author
Date
1.2.1
106kB
Dave
07-31-2012 08:43 AM
1.2
105kB
Dave
07-27-2012 05:25 PM
1.1.1
105kB
Dave
07-25-2012 09:38 AM
1.0
104kB
Dave
07-24-2012 05:42 PM


Post A Reply Comment Options
Unread 08-05-2012, 11:15 AM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
Quote:
Originally Posted by snap
No it doesent fix it.
i see When i make the Transparent of tthe Action Buttons to 0 than the black Buttuns are the same as the Action Buttons. its a clone of the Action Buttons.
Some Member of the Cabale have the same error. We have the German Client , its that the problem?

MFG Snap
It could be one of those random problems that some are having since 1.1. Does it always do this on death or zoning?

I can't know for certain, but the language of your client shouldn't matter.
Dave is offline Report comment to moderator  
Reply With Quote
Unread 08-05-2012, 08:10 AM  
snap

Forum posts: 0
File comments: 7
Uploads: 0
No it doesent fix it.
i see When i make the Transparent of tthe Action Buttons to 0 than the black Buttuns are the same as the Action Buttons. its a clone of the Action Buttons.
Some Member of the Cabale have the same error. We have the German Client , its that the problem?

MFG Snap
Last edited by snap : 08-05-2012 at 08:33 AM.
snap is offline Report comment to moderator  
Reply With Quote
Unread 08-05-2012, 06:28 AM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
Re: Can you shut off tooltips for the hotbar (or give the option to do so)?

Quote:
Originally Posted by Charon
First off, thanks for creating this - I'm using it with the default placement and it's made life *MUCH* easier for me since I can now minimize mouse movement (yeah, I'm one of those weird clicker people, not a keyboarder, when it comes to ability use ).

So here's one minor difficulty I have with the new setup: now that the bar is near the center of the screen, the tooltips that show up when I'm mousing over the hotbar cover things like resources and enemy health... or sometimes block other needed elements of the display. I know I can turn off all tooltips from the game settings, but that also turns them off when I'm in the ability window, which is just plain annoying (probably not the best design choice to only have one option to shut off tooltips, everywhere, but that's what Funcom decided to do).

I don't even know if you have the option to shut off tooltips for just your displayed elements, but if you can, could this option be added to your addon? That would greatly enhance it, for my usage.

Either way, awesome add on. Thanks much for your work!

-Charon
I had a look and it seems tooltips are stored somewhere else than positions, etc. I may try to find out where or how to access at a later stage, as I'm concentrating on getting Custom UI 2 ready.

Quote:
Originally Posted by snap
Hello , thanks for this Addon. One Thing dont work for me. I place all things (Action Bars , casting Bars etc.) where i want to have it. I Start the Game all is ok. But when i die or go in a single Instance (all things where the Game must load contend) i have under my Action Buttons black Buttons. I reload ui and all is ok. Than /cui and all is ok. But when i die or the Game must load contend i have black Buttons under my Action Buttons. Can you help me what i must do so that i dont become these black Buttons under my Action Buttons?


MFG Snap
Does pressing N twice fix it?
Dave is offline Report comment to moderator  
Reply With Quote
Unread 08-05-2012, 05:35 AM  
snap

Forum posts: 0
File comments: 7
Uploads: 0
Hello , thanks for this Addon. One Thing dont work for me. I place all things (Action Bars , casting Bars etc.) where i want to have it. I Start the Game all is ok. But when i die or go in a single Instance (all things where the Game must load contend) i have under my Action Buttons black Buttons. I reload ui and all is ok. Than /cui and all is ok. But when i die or the Game must load contend i have black Buttons under my Action Buttons. Can you help me what i must do so that i dont become these black Buttons under my Action Buttons?


MFG Snap
snap is offline Report comment to moderator  
Reply With Quote
Unread 08-04-2012, 08:50 PM  
Charon

Forum posts: 0
File comments: 1
Uploads: 0
Can you shut off tooltips for the hotbar (or give the option to do so)?

First off, thanks for creating this - I'm using it with the default placement and it's made life *MUCH* easier for me since I can now minimize mouse movement (yeah, I'm one of those weird clicker people, not a keyboarder, when it comes to ability use ).

So here's one minor difficulty I have with the new setup: now that the bar is near the center of the screen, the tooltips that show up when I'm mousing over the hotbar cover things like resources and enemy health... or sometimes block other needed elements of the display. I know I can turn off all tooltips from the game settings, but that also turns them off when I'm in the ability window, which is just plain annoying (probably not the best design choice to only have one option to shut off tooltips, everywhere, but that's what Funcom decided to do).

I don't even know if you have the option to shut off tooltips for just your displayed elements, but if you can, could this option be added to your addon? That would greatly enhance it, for my usage.

Either way, awesome add on. Thanks much for your work!

-Charon
Charon is offline Report comment to moderator  
Reply With Quote
Unread 08-03-2012, 05:06 PM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
Quote:
Originally Posted by disqord
Quote:
Originally Posted by Dave
You can also do '/auto_login' to save copy and pasting. Just to check, are your scripts in the '....The Secret World\Scripts' directory?
yes, it IS in the scripts folder; which is why I don't understand why its not working... I've got pinstripesc's Emotes [Lux'd] script in that same folder and that works just fine when enter in the right command.

buy "/auto_login" do you mean add that line to the script towards the top? or is it the format of the script file that needs to change? The script that came with cUI was just called "file" when i queried it under preferences in windows, should it be txt?
You type '/auto_login' into a chat window to run the script and make sure it is working. Some people are having random issues involving the resource bars since the 1.1 patch, maybe this is another rare issue.

You can call script files whatever you want. If you call it 'script.txt', then you do '/script.txt' in a chat window.
Dave is offline Report comment to moderator  
Reply With Quote
Unread 08-03-2012, 04:54 PM  
disqord

Forum posts: 0
File comments: 4
Uploads: 0
Quote:
Originally Posted by Dave
You can also do '/auto_login' to save copy and pasting. Just to check, are your scripts in the '....The Secret World\Scripts' directory?
yes, it IS in the scripts folder; which is why I don't understand why its not working... I've got pinstripesc's Emotes [Lux'd] script in that same folder and that works just fine when enter in the right command.

buy "/auto_login" do you mean add that line to the script towards the top? or is it the format of the script file that needs to change? The script that came with cUI was just called "file" when i queried it under preferences in windows, should it be txt?
disqord is offline Report comment to moderator  
Reply With Quote
Unread 08-03-2012, 06:42 AM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
Quote:
Originally Posted by disqord
So - I'm not the fastest typist in the world, alright? Even copy/paste is only so fast, but still...

I take something like 2 hours. I get the UI JUST the way I want it, save the values to the CUI script file, delete the unused lines, make sure to up the /delay line (/delay 1000 in this case) quit the game, then load back in...

...and the UI is back where it initially started

/fliptable

**** it, I'll just wait for something better, like an ingame editor or something. This script **** is way beyond me...
You can also do '/auto_login' to save copy and pasting. Just to check, are your scripts in the '....The Secret World\Scripts' directory?
Dave is offline Report comment to moderator  
Reply With Quote
Unread 08-03-2012, 05:58 AM  
disqord

Forum posts: 0
File comments: 4
Uploads: 0
So - I'm not the fastest typist in the world, alright? Even copy/paste is only so fast, but still...

I take something like 2 hours. I get the UI JUST the way I want it, save the values to the CUI script file, delete the unused lines, make sure to up the /delay line (/delay 1000 in this case) quit the game, then load back in...

...and the UI is back where it initially started

/fliptable

**** it, I'll just wait for something better, like an ingame editor or something. This script **** is way beyond me...
disqord is offline Report comment to moderator  
Reply With Quote
Unread 08-02-2012, 08:55 PM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
Quote:
Originally Posted by disqord
Dave,

Love the customization in this UI mod, but I have one question: tinkering with the values produces a decent UI for me, but whenever I back all the way out of the game then relog, SOME of the elements stay put, but not all - usually the Ability Bar, casting bars, and Target bar all revert to the "default" in the cui file with the mod.

I've changed the file name to "auto_login"
I've added "delay 500" at the the top of the script
I've also made sure that "/option cuiUpdate true" is used at the bottom of the script, and in game while moving things around as opposed to double-N'ing to refresh the screen layout.

can you tell me what I'm doing wrong? I'm getting tired of manually re-entering the same values over and over again from the script.
It looks like your not doing anything wrong. So you copy and paste from the script to fix it? If so, then you may need to increase the delay.
Dave is offline Report comment to moderator  
Reply With Quote
Unread 08-02-2012, 07:41 PM  
disqord

Forum posts: 0
File comments: 4
Uploads: 0
Dave,

Love the customization in this UI mod, but I have one question: tinkering with the values produces a decent UI for me, but whenever I back all the way out of the game then relog, SOME of the elements stay put, but not all - usually the Ability Bar, casting bars, and Target bar all revert to the "default" in the cui file with the mod.

I've changed the file name to "auto_login"
I've added "delay 500" at the the top of the script
I've also made sure that "/option cuiUpdate true" is used at the bottom of the script, and in game while moving things around as opposed to double-N'ing to refresh the screen layout.

can you tell me what I'm doing wrong? I'm getting tired of manually re-entering the same values over and over again from the script.
Last edited by disqord : 08-02-2012 at 08:01 PM.
disqord is offline Report comment to moderator  
Reply With Quote
Unread 08-01-2012, 03:10 PM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
Quote:
Originally Posted by Devla
Would it be possible to functions for the 'anima' frame that pops up in dungeons when you die. It has the icons to watch the fight, repair or exit.

Thanks
I just tried, but couldn't find the variable name. I try looking through the source at some point.
Dave is offline Report comment to moderator  
Reply With Quote
Unread 07-31-2012, 03:36 PM  
Devla
AddOn Author - Click to view AddOns

Forum posts: 4
File comments: 21
Uploads: 1
Would it be possible to functions for the 'anima' frame that pops up in dungeons when you die. It has the icons to watch the fight, repair or exit.

Thanks
Devla is offline Report comment to moderator  
Reply With Quote
Unread 07-31-2012, 01:00 PM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
I most likely will not be adding new features until the experimental version is ready, as it would mean doing the work twice.

Thanks.
Dave is offline Report comment to moderator  
Reply With Quote
Unread 07-31-2012, 12:56 PM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
Quote:
Originally Posted by kenze
great i got the scale to work, thanks. I got everything positioned where i want it.. how do i get it to save though? next time i logged in everything was reset.
You need to make a script.
Dave is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.