Quantcast
Download
(268 Kb)
Download
Updated: 08-01-2012 07:18 PM
Addon for:
Custom UI.
Pictures
File Info
Updated:08-01-2012 07:18 PM
Created:07-30-2012 07:51 AM
Downloads:474
Favorites:5
MD5:
Custom UI Layout (Experimental)
Version: 0.4
by: Dave [More]
Moved to http://uimod.eu/.
Archived Files (3)
File Name
Version
Size
Author
Date
0.3.1
267kB
Dave
08-01-2012 01:31 PM
0.2
264kB
Dave
07-31-2012 03:19 PM
0.1
158kB
Dave
07-30-2012 07:51 AM


Post A Reply Comment Options
Unread 08-08-2012, 01:53 AM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
I won't be monitoring this thread anymore as it would be much easier if everyone posted in the same place: http://uimod.eu/forums/ or http://forums.thesecretworld.com/showthread.php?t=53205 if prefered.

The forums at http://uimod.eu/forums/ is a Google Group so you don't need to register, just be logged in with Google to be able to post.

Thanks.

Quote:
Originally Posted by fostot
Quote:
Originally Posted by fostot
Even after using the latest 2.0 beta 2 I still cannot get this addon working, not even when using /option cuiOpen true, it says that cuiOpen isn't a valid option.

I think this may be a conflict with Viper's Addons.
I deleted all of my addons and all of my settings completely and reinstalled and this addon now works. I did not have the CustomUI settings you suggested on the forums so something else had to have caused it.
That's strange.
Last edited by Dave : 08-15-2012 at 12:04 PM.
Dave is offline Report comment to moderator  
Reply With Quote
Unread 08-07-2012, 08:14 PM  
fostot

Forum posts: 0
File comments: 13
Uploads: 0
Quote:
Originally Posted by fostot
Even after using the latest 2.0 beta 2 I still cannot get this addon working, not even when using /option cuiOpen true, it says that cuiOpen isn't a valid option.

I think this may be a conflict with Viper's Addons.
I deleted all of my addons and all of my settings completely and reinstalled and this addon now works. I did not have the CustomUI settings you suggested on the forums so something else had to have caused it.
fostot is offline Report comment to moderator  
Reply With Quote
Unread 08-07-2012, 08:13 PM  
fostot

Forum posts: 0
File comments: 13
Uploads: 0
Even after using the latest 2.0 beta 2 I still cannot get this addon working, not even when using /option cuiOpen true, it says that cuiOpen isn't a valid option.

I think this may be a conflict with Viper's Addons.
fostot is offline Report comment to moderator  
Reply With Quote
Unread 08-07-2012, 05:05 PM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
Quote:
Originally Posted by fostot
I installed 2.0 beta 1 and it doesn't have a way for configuring that I can find. I assumed an Icon would appear like in the screenshots but nothing. Any ideas?
You may have to clean up your ....\The Secret World\Data\Gui\Customized\ directory.

You may also need to delete your configuration: http://forums.thesecretworld.com/sho...67#post1341767
Dave is offline Report comment to moderator  
Reply With Quote
Unread 08-07-2012, 12:02 PM  
fostot

Forum posts: 0
File comments: 13
Uploads: 0
I installed 2.0 beta 1 and it doesn't have a way for configuring that I can find. I assumed an Icon would appear like in the screenshots but nothing. Any ideas?
fostot is offline Report comment to moderator  
Reply With Quote
Unread 08-06-2012, 05:36 PM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
Quote:
Originally Posted by fostot
Have you thought of doing like Viper / Other Dev's have done and instead of having an external script using the Variables that are available in the settings so that you can instead of having the user write an auto_login script just read the variable and update the layout from that? An example of this would be Viper's Deck Manager. He sets the variables and they get stored in the users %AppData%\..\Local\Funcom\ Character\Prefs2.xml file.

Just a suggestion Scripts aren't hard to do and are rewarding because people can share them. I just have noticed a LOT of people seriously confused by it in my guild when i'm trying to explain it to them haha
Yes, I have that in now. Previous versions were not modules as such and therefore don't have access to the auto loading and saving of data.

Custom UI 2beta0 is now available at http://uimod.eu/. Fully GUI driven now so should be much easier for your guild members (when I have written the documentation).

I also like the idea of sharing scripts, so I plan to add the ability to copy and paste the data within the UI.
Dave is offline Report comment to moderator  
Reply With Quote
Unread 08-06-2012, 05:14 PM  
fostot

Forum posts: 0
File comments: 13
Uploads: 0
Have you thought of doing like Viper / Other Dev's have done and instead of having an external script using the Variables that are available in the settings so that you can instead of having the user write an auto_login script just read the variable and update the layout from that? An example of this would be Viper's Deck Manager. He sets the variables and they get stored in the users %AppData%\..\Local\Funcom\ Character\Prefs2.xml file.

Just a suggestion Scripts aren't hard to do and are rewarding because people can share them. I just have noticed a LOT of people seriously confused by it in my guild when i'm trying to explain it to them haha
fostot is offline Report comment to moderator  
Reply With Quote
Unread 08-06-2012, 04:36 AM  
kenze

Forum posts: 9
File comments: 10
Uploads: 0
Quote:
Originally Posted by Dave
Quote:
Originally Posted by kenze
Quote:
Originally Posted by Dave
..not making ANY accusations here, but 2 different antivirus products on 2 different computers both block that website from opening. The message goes something like "The web page is on the list of websites with potentially dangerous content." Any idea why?
Thanks for letting me know. The .co.cc domain names are free, and just found out yesterday that they are used by spammers...
Anyway, I just registered http://uimod.eu/ which should be available within 24 hours.
very awesome! and thanks for the response. I look forward to your new site and following customui.
kenze is offline Report comment to moderator  
Reply With Quote
Unread 08-06-2012, 04:29 AM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
Quote:
Originally Posted by kenze
Quote:
Originally Posted by Dave
..not making ANY accusations here, but 2 different antivirus products on 2 different computers both block that website from opening. The message goes something like "The web page is on the list of websites with potentially dangerous content." Any idea why?
Thanks for letting me know. The .co.cc domain names are free, and just found out yesterday that they are used by spammers...
Anyway, I just registered http://uimod.eu/ which should be available within 24 hours.
Dave is offline Report comment to moderator  
Reply With Quote
Unread 08-06-2012, 04:19 AM  
kenze

Forum posts: 9
File comments: 10
Uploads: 0
Quote:
Originally Posted by Dave
..not making ANY accusations here, but 2 different antivirus products on 2 different computers both block that website from opening. The message goes something like "The web page is on the list of websites with potentially dangerous content." Any idea why?
kenze is offline Report comment to moderator  
Reply With Quote
Unread 08-05-2012, 05:24 PM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
Quote:
Originally Posted by Furiant
With the issue of the SP/AP rack getting moved to the top left of the screen after zoning, conversations, etc.: I've narrowed this down to this addon. I have a feeling it has something to do with your replacement of PrecompiledClasses.swf.

Really, I'm not sure why FC would want you to do that; if anyone else needed to alter those classes they'd also need to replace that file (at least with the way you have it, in the Flash directory), so we'd only ever be able to use one addon that did so. I don't do Flash development so I don't know the subtleties of the API, but I am a software developer and that just doesn't seem like a good design approach.

In any case calling /reloadui and then calling my settings script does fix it - it's just tedious to do this after every UI refresh of any kind. May be worth looking into.

Still loving the addon; I'd have quit the game without it.
I only changed com.Utils.HUDController, which unfortunately is included into PrecompiledClasses.swf. I agree that it is a strange system.

The development version is barely usable at the moment, but I have started a new version from scratch (with copy and pasting). I wanted to wait until it is at least as usable as the current version. I just need to fix one issue and then hopefully it will be ready for testing tomorrow. It has an icon and loads and saves settings, so no need for scripts any more.

To make it a bit easier to organise, I made a site for it at: http://customui.co.cc/.
Dave is offline Report comment to moderator  
Reply With Quote
Unread 08-05-2012, 04:15 PM  
Furiant

Forum posts: 1
File comments: 7
Uploads: 0
With the issue of the SP/AP rack getting moved to the top left of the screen after zoning, conversations, etc.: I've narrowed this down to this addon. I have a feeling it has something to do with your replacement of PrecompiledClasses.swf.

Really, I'm not sure why FC would want you to do that; if anyone else needed to alter those classes they'd also need to replace that file (at least with the way you have it, in the Flash directory), so we'd only ever be able to use one addon that did so. I don't do Flash development so I don't know the subtleties of the API, but I am a software developer and that just doesn't seem like a good design approach.

In any case calling /reloadui and then calling my settings script does fix it - it's just tedious to do this after every UI refresh of any kind. May be worth looking into.

Still loving the addon; I'd have quit the game without it.
Last edited by Furiant : 08-05-2012 at 04:17 PM.
Furiant is offline Report comment to moderator  
Reply With Quote
Unread 08-04-2012, 03:20 AM  
Dave
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 43
Uploads: 3
Quote:
Originally Posted by disqord
EDIT: christ on a cross... didn't realize it shows up as System text; i.e. the layout link is generated in the System Channel so unless you're subscribed to see it in the chat window, you won't see it period. :S Better make a note of that Dave! Not all of us use the system chat channel ya know :P
I didn't think to check, thanks. I assumed it would go to the default chat window.

Quote:
Originally Posted by Devla
The ability bar shadow exists in 0.4

Also, I noticed that upon /reloadui, the UI resets position. A simple load of whatever cui script file will adjust things back, but wondering why/how this is happening. I've got auto_login and auto_teleport loading the cui script, but upon reloadui it resets.

One other quick thing, I noticed that running Viper's Castbar Relocator with CustomUI really doesn't work too well. I'm sure both mods use similar things, not sure how compatible they are.

Thanks!
I think I may just start again and break compatibility with all previous scripts. I added a few new features since the last version but I think people would prefer a stable version soon.

If both mods move the cast bars, then I guess it's not a surprise there may be issues.
Dave is offline Report comment to moderator  
Reply With Quote
Unread 08-03-2012, 06:48 PM  
Devla
AddOn Author - Click to view AddOns

Forum posts: 4
File comments: 21
Uploads: 1
The ability bar shadow exists in 0.4

Also, I noticed that upon /reloadui, the UI resets position. A simple load of whatever cui script file will adjust things back, but wondering why/how this is happening. I've got auto_login and auto_teleport loading the cui script, but upon reloadui it resets.

One other quick thing, I noticed that running Viper's Castbar Relocator with CustomUI really doesn't work too well. I'm sure both mods use similar things, not sure how compatible they are.

Thanks!
Devla is offline Report comment to moderator  
Reply With Quote
Unread 08-03-2012, 05:58 PM  
disqord

Forum posts: 0
File comments: 4
Uploads: 0
Quote:
Originally Posted by Dave
Quote:
Originally Posted by Devla
Quote:
Originally Posted by Dave
You can use the generate script button then copy and paste.
Thanks! Not sure how this works, I've tried clicking the generate script button and nothing seems to happen. What/where am I copying?
When you click 'Generate Script', you should get a link it your chat window which opens a window with the text that needs to be copied into a script.
not working for me; link doesn't appear in chat, and i redid my chat windows too like the launcher said after the update

EDIT: christ on a cross... didn't realize it shows up as System text; i.e. the layout link is generated in the System Channel so unless you're subscribed to see it in the chat window, you won't see it period. :S Better make a note of that Dave! Not all of us use the system chat channel ya know :P
Last edited by disqord : 08-03-2012 at 07:22 PM.
disqord is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: